ACAPI_​AddOnObject_​GetObjectContent

Retrieves the content and the name of the specified AddOnObject from the project database.

    GSErrCode  ACAPI_AddOnObject_GetObjectContent (
        const API_Guid&     objectGuid,
        GS::UniString*      objectName,
        GSHandle*           objectContent
    );

 

Parameters

objectGuid
[in] The GUID of the object.
objectName
[out] The name of the specified object.
objectContent
[out] The content of the specified object.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The passed parameter objectGuid is APINULLGuid or either objectName or objectContent is nullptr.
APIERR_BADID
No object with the specified GUID exists.

For other common API errors see the API Errors document.

 

Remarks

Archicad allocates the target buffer in content parameter; the caller add-on is responsible to dispose it with BMKillHandle.

 

Requirements

Version: API 19 or later
Header: ACAPinc.h

 

See Also

AddOnObject Manager,
API Functions