API_​3D_​Head

Common header for the 3D components.

    typedef struct {
        API_3DTypeID     typeID;
        Int32            index;
        Int32            elemIndex;
        Int32            bodyIndex;
    } API_3D_Head;

 

Members

typeID
Identifies the type of the component.
index
The index field gives the current database index of the given component. Note that this number is not constant for a particular element through the whole life of the project element index.
elemIndex New in API 12
Gives the internal element index plus one for a body; output only parameter for API_BodyType. It can be used to get the (u,v) texture coordinates with APIAny_GetTextureCoordID.
bodyIndex New in API 12
Gives the internal body index plus one for a body; output only parameter for API_BodyType. It can be used to get the (u,v) texture coordinates with APIAny_GetTextureCoordID.

 

Remarks

This structure specify the type and the database index of a 3D component.

You can get a 3D component by the ACAPI_3D_GetComponent function. Give the type and index information in the appropriate fields of the header of an API_Component3D structure, and you will get its other parameters.

 

Example

Several uses of this an other 3D-related structures can be found in the 3D_Test sample project.

 

Requirements

Version: API 1.3 or later
Header: APIdefs_3D.h

 

See Also

API_3DTypeID, API_Component3D,
3D Manager, API Types