Instructs the host application to keep the add-on in the memory after execution.
void ACAPI_KeepInMemory ( bool keepIn );
Parameters
- keepIn
- [in] If
true
the add-on will stay in the memory.
Remarks
This function is used to keep the add-on in the memory.
You should call this function with true
each time your add-on is called to stay in memory. The values of all your global variables stay the same between the calls to your add-on. Also, when in memory, the Initialize and the FreeData functions of your add-on are not called. See more about this topic at the Control the Load/Unload Mechanism part of the Tips and Tricks.
Requirements
- Version: API 1.3 or later
- Header: ACAPinc.h
See Also
Initialize, FreeData,
Control the Load/Unload Mechanism,
API Functions