ACAPI_​AddOnObject_​CreateClientOnlyObject

Creates an AddOnObject.

    GSErrCode  ACAPI_AddOnObject_CreateClientOnlyObject (
        const GS::UniString&     objectName,
        const GSHandle&          content,
        API_Guid*                objectGuid
    );

 

Parameters

objectName
[in] The name of the AddOnObject.
content
[in] The content of the AddOnObject.
objectGuid
[out] The GUID of the created object.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function is used to store custom data into project database. The custom data is represented by AddOnObject.

This data is avaible in teamwork only in clinet side, it won’t be send to the teamwork server. If you need to ensure that the AddOnObject send between users use ACAPI_AddOnObject_CreateObject.

The content handle will be copied inside the function so it has to be deleted after the function call.

The stored data can be accessed using objectGuid parameter. The objectName parameter can also be used for identifying the custom data. It can be also emtpy. Archicad does not check if the name is unique.

If you need to ensure that only one AddOnObject exists with the same name, then use Unique AddOnObjects. See more: ACAPI_AddOnObject_CreateUniqueObject.

 

Requirements

Version: API 23 or later
Header: ACAPinc.h

 

See Also

ACAPI_AddOnObject_DeleteObject, AddOnObject Manager, API Functions