Creates more Unique AddOnObjects.
GSErrCode ACAPI_AddOnObject_CreateUniqueObjectMore ( const GS::Array<GS::UniString>& objectNames, GS::Array<API_Guid>& objectGuids );
Parameters
- objectNames
- [in] The names of the Unique AddOnObjects. The names must be unique.
- objectGuid
- [out] The GUIDs of the created objects. One guid is returned to each given name. Empty array is returned if an error happened.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- If the objectNames array is empty or the names in it are not unique among each other.
APIERR_NAMEALREADYUSED
- If there is already a Unique AddOnObject with one of the given objectNames.
APIERR_NOTEAMWORKPROJECT
- Indicates that the project is an Offline TeamWork project. Due to possible conflicts, it is not allowed to create Unique AddOnObjects in an Offline Teamwork Project.
APIERR_SERVICEFAILED
- The created Unique AddOnObjects could not be sent to the TeamWork server.
For other common API errors see the API Errors document.
Remarks
In a TeamWork project creating Unique AddOnObjects will result in a Full Receive and a Full Send to ensure project consistency. Due to this inconvenience, it is possible to create more Unique AddOnObjects at once with this function.
For more info, see ACAPI_AddOnObject_CreateUniqueObject.
Requirements
- Version: API 21 or later
- Header: ACAPinc.h