Determines if the project database contains the specified AddOnObject or not.
GSErrCode ACAPI_AddOnObject_ExistsObject ( const API_Guid& objectGuid, bool* objectExists );
Parameters
- objectGuid
- [in] The GUID of the specified object..
- objectExists
- [out]
true
if the object exists, otherwisefalse
.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The passed parameter objectGuid is
APINULLGuid
or objectExists isnullptr
APIERR_BADID
- The object specified by GUID exists, but its type is not AddOnObject.
For other common API errors see the API Errors document.
Requirements
- Version: API 19 or later
- Header: ACAPinc.h