ACAPI_​AddOnObject_​GetClientOnlyObjectGuidFromName

Returns the GUID of the specified object.

    GSErrCode  ACAPI_AddOnObject_GetClientOnlyObjectGuidFromName (
        const GS::UniString&     name,
        API_Guid*                objectGuid
    );

 

Parameters

name
[in] The name of the specified object.
objectGuid
[out] The GUID of the object, if the project database contains AddOnObject with the specified name, otherwise APINULLGuid.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The passed parameter objectGuid is nullptr.

For other common API errors see the API Errors document.

 

Remarks

If more AddOnObjects exist with the same name, it is not specified which GUID will be returned.

Please note that this is a linear time function.

This function cannot be used to get the GUID of a Unique AddOnObject or AddOnObject or the get GUID-s from other teamwork users.

You can use Unique AddOnObjects if it is important to have only one AddOnObject with the same name. See AddOnObject Manager for more information.

 

Requirements

Version: API 23 or later
Header: ACAPinc.h

 

See Also

AddOnObject Manager, API Functions