ACAPI_​AddOnObject_​GetTeamworkOwnerId

Returns the ownerId of the specified object in teamwork mode.

    GSErrCode  ACAPI_AddOnObject_GetTeamworkOwnerId (
        const API_Guid&     objectGuid,
        short*              ownerId
    );

 

Parameters

objectGuid
[in] The GUID of the specified object.
ownerId
[out] The teamwork owner user of the specified object.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The passed parameter objectGuid is APINULLGuid or ownerId is nullptr
APIERR_BADID
AddOnObject does not exist.

For other common API errors see the API Errors document.

 

Requirements

Version: API 19 or later
Header: ACAPinc.h

 

See Also

AddOnObject Manager, API Functions