ACAPI_​AddOnObject_​GetUniqueObjectGuidFromName

Returns the GUID of the specified Unique AddOnObject.

    GSErrCode  ACAPI_AddOnObject_GetUniqueObjectGuidFromName (
        const GS::UniString&     name,
        API_Guid*                objectGuid
    );

 

Parameters

name
[in] The name of the specified object.
objectGuid
[out] The GUID of the object, if the project database contains Unique AddOnObject with the specified name, otherwise APINULLGuid.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The passed parameter objectGuid is NULL.

For other common API errors see the API Errors document.

 

Remarks

This function cannot be used to get the GUID of a general (non-unique) AddOnObject.

Please note that this is a linear time function.

This function cannot be used to get the GUID of a general (non-unique) AddOnObject.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

AddOnObject Manager, API Functions