ACAPI_​AddOnObject_​ModifyObject

Modifies the content and/or the name of the specified AddOnObject.

    GSErrCode  ACAPI_AddOnObject_ModifyObject (
        const API_Guid&          objectGuid,
        const GS::UniString*     newObjectName,
        const GSHandle*          newObjectContent
    );

 

Parameters

objectGuid
[in] The GUID of the object.
newObjectName
[in] The new name of the specified object. If nullptr, the name of the object remains the original name. Must be nullptr if modifying a Unique AddOnObject.
newObjectContent
[in] The new content of the specified object. If nullptr, the content of the object remains the original content. Must not be nullptr if modifying a Unique AddOnObject.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
  • If the passed objectGuid parameter is NULLGuid, or
  • if neither newObjectName nor newObjectContent is filled, or
  • if modifying a Unique AddOnObject and either newObjectName is not nullptr (it must be) or newObjectContent is nullptr (it must not be).
APIERR_BADID
The specified object does not exist.
APIERR_NOTMINE
The object is not owned by the current user in teamwork mode.

For other common API errors see the API Errors document.

 

Remarks

This function is used for modifying the content or the name of the specified AddOnObject.

The newObjectContent handle will be copied inside the function so it has to be deleted after the function call.

 

Requirements

Version: API 19 or later
Header: ACAPinc.h

 

See Also

ACAPI_AddOnObject_CreateObject, ACAPI_AddOnObject_DeleteObject AddOnObject Manager, API Functions