In teamwork mode this function sends a request mail in order to request the specified objects from the owners.
GSErrCode ACAPI_AddOnObject_RequestObjects ( const GS::Array<API_Guid>& objectGuids, const GS::UniString& mailText );
Parameters
- objectGuids
- [in] The list of the objects which must be requested.
- mailText
- [in] The text of the request mail.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The passed parameter
objectGuids
is empty or containsAPINULLGuid
. APIERR_BADID
- If any of the
objectGuids
is not an AddOnObject GUID.
For other common API errors see the API Errors document.
Requirements
- Version: API 19 or later
- Header: ACAPinc.h