ACAPI_​AddOnObject_​ReserveObjects

In teamwork mode this function reserves the specified objects.

    GSErrCode  ACAPI_AddOnObject_ReserveObjects (
        const GS::Array<API_Guid>&        objectGuids,
        GS::HashTable<API_Guid, short>*     conflicts
    );

 

Parameters

objectGuids
[in] The list of the objects which must be released.
conflicts
[out] Can be nullptr. If some of the specified objects cannot be reserved because of reservations of other users, this table will be filled with the conflicts.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The passed parameter objectGuids is empty or contains APINULLGuid.
APIERR_BADID
If any of the objectGuids is not an AddOnObject GUID.

For other common API errors see the API Errors document.

 

Remarks

If any of the specified objects were modified by another user, Receive Changes operation will be performed in order to get the latest version of the objects from the server.

 

Requirements

Version: API 19 or later
Header: ACAPinc.h

 

See Also

AddOnObject Manager, API Functions