ACAPI_​AddOnObject_​SetUIProperties

Sets various UI properties of an AddOnObject.

    GSErrCode  ACAPI_AddOnObject_SetUIProperties (
        const API_Guid*          objectGuid,
        const GS::UniString*     name,
        const GS::UniString&     localisedName,
        short                    dialogMenuStringId
    );

 

Parameters

objectGuid
[in] GUID of the specified object. Can be NULL if name-based identification is intended.
name
[in] The name of the specified object. Can be NULL if only GUID-based identification is intended.
localisedName
[in] The localised name of the specified object (or objects if objectGuid is NULL and there are more AddOnObjects with the same name).
dialogMenuStringId
[in] The id of the menu which must be called if Show button is pressed on Teamwork User interface.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Both objectGuid and name are NULL, or localisedName is empty string.

For other common API errors see the API Errors document.

 

Remarks

This function is used to register UI properties for AddOnObject. UI properties are localised name and the menu command id. The registered properties will be used for all AddOnObjects which have the specified GUID or name.

If Archicad looks for a UI property, first tries to find it by GUID. If the property is not found, Archicad also tries to find it by name. So the registration can be done even if no instance of AddOnObject exists: in this case objectGuid should be NULL. Please note that if only the name is given for a UI property, then all AddOnObjects (both general and unique) with this name will have the same UI property.

 

Requirements

Version: API 19 or later
Header: ACAPinc.h

 

See Also

AddOnObject Manager, API Functions