Adds a Load Case (with its adherent coefficients) to a Load Combination identified with guid.
GSErrCode ACAPI_AnalyticalModel_AddLoadCaseToLoadCombination ( const API_AnalyticalLoadFactor& loadFactor, const API_Guid& analyticalLoadCombinationGuid );
Parameters
- loadFactor
- [in] Analytical Load Factor (load case guid, load factor and multiplier) which will be added to the Load combination.
- analyticalLoadCombinationGuid
- [in] Unique identifier of the Load combination.
Return Values
NoError
- The function has completed with success.
For other common API errors see the API Errors document.
Requirements
- Version: API 25 or later
- Header: ACAPI_Analytical_Adapter.hpp