ACAPI_​AnalyticalModel_​CreateElementFromCurveMember

Creates an element from the Structural Analytical Model Curve Member.

    GSErrCode  ACAPI_AnalyticalModel_CreateElementFromCurveMember (
        API_AnalyticalCurveMember&         api_curveMember,
        const GS::OptionalGS::UniString>& favoriteName = GS::NoValue,
    );

 

Parameters

api_curveMemberAPI 26 feature
[in/out] The Curve Member to create the element from. After a successful creation, it is filled with the unique identifier of the created element.
favoriteNameAPI 26 feature
[in] The name of the Favorite Element which contains the settings for the new element, otherwise the settings are taken from the element default.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

The ProfileVectorImage parameter for Custom Profiles has been moved into API_AnalyticalCrossSection

 

Requirements

Version: API 24 or later
Header: .\ACAPI_Analytical_Adapter.hpp

 

See Also

API Functions