ACAPI_​AnalyticalModel_​CreateElementFromSegmentedSurfaceMember

Creates an element from the Structural Analytical Model Surface Member segments.

    GSErrCode  ACAPI_AnalyticalModel_CreateElementFromSegmentedSurfaceMember (
        GS::Array<API_AnalyticalSurfaceMember>&  api_surfaceMember,
        const GS::OptionalGS::UniString>&	 favoriteName = GS::NoValue,
        API_ImportIdMappingType*                 idMapping = nullptr
    );

 

Parameters

api_surfaceMemberAPI 26 feature
[in/out] The Surface Member to create the element from. After a successful creation, the first segment from the array is filled with the unique identifier of the created element.
favoriteNameAPI 26 feature
[in] The name of the Favorite Element which contains the settings for the new element, otherwise the settings are taken from the element default.
idMapping
[out] An optional parameter for the mapping between Segment Surface Member edge&vertex ID and generated Surface Element Member Part Reference.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Requirements

Version: API 24 or later
Header: .\ACAPI_Analytical_Adapter.hpp

 

See Also

API Functions