Creates an element from the Structural Analytical Model Surface Member.
GSErrCode ACAPI_AnalyticalModel_CreateElementFromSurfaceMember ( API_AnalyticalSurfaceMember& api_surfaceMember, const GS::OptionalGS::UniString>& favoriteName = GS::NoValue, API_ImportIdMappingType* idMapping = nullptr );
Parameters
- api_surfaceMember
- [in/out] The Surface Member to create the element from. After a successful creation, it is filled with the unique identifier of the created element.
- favoriteName
- [in] The name of the Favorite Element which contains the settings for the new element, otherwise the settings are taken from the element default.
- idMapping
- [out] An optional paramter which stores the mapping table for the edges and vertices of the member.
Return Values
NoError
- The function has completed with success.
For other common API errors see the API Errors document.
Requirements
- Version: API 24 or later
- Header: .\ACAPI_Analytical_Adapter.hpp