ACAPI_​AnalyticalModel_​GetAnalyticalLinkGeometry

Returns the Structural Analytical Link Geometry.

    GSErrCode  ACAPI_AnalyticalModel_GetAnalyticalLinkGeometry (
        const API_Guid&                amGuid,
        const API_Guid&                elemGuid,
        API_AnalyticalLinkGeometry&    api_analyticalLinkGeometry
    );

 

Parameters

amGuid
[in] The unique identifier of the internal Structural Analytical Model.
elemGuid
[in] The unique identifier of the internal Curve Element.
api_analyticalLinkGeometry
[out] The Structural Analytical Link geometry.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Requirements

Version: API 24 or later
Header: .\ACAPI_Analytical_Adapter.hpp

 

See Also

API Functions