ACAPI_​AnalyticalModel_​GetAnalyticalMemberConnections

Returns the guids of elements which are connected to a Structural Analytical Member, given by it’s guid. Includes elements which are connected by Structural Analytical Links.

    GSErrCode  ACAPI_AnalyticalModel_GetAnalyticalMemberConnections (
        const API_Guid&            amGuid,
        const API_Guid&            elemGuid,
        GS::HashSet<API_Guid>&     api_connections
    );

 

Parameters

amGuid
[in] The unique identifier of the internal Structural Analytical Model.
elemGuid
[in] The unique identifier of the Structural Analytical Member.
api_connections
[out] The elements connected to the given Structural Analytical Member.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Requirements

Version: API 24 or later
Header: .\ACAPI_Analytical_Adapter.hpp

 

See Also

API Functions