ACAPI_​AnalyticalModel_​GetAnalyticalRelease

Returns the Structural Analytical Model Member Relase associated with the selected Curve Element.

    GSErrCode  ACAPI_AnalyticalModel_GetAnalyticalRelease (
        const API_Guid&                amGuid,
        const API_Guid&                elemGuid,
        API_AnalyticalReleaseType&     api_analyticalRelease
    );

 

Parameters

amGuid
[in] The unique identifier of the internal Structural Analytical Model.
elemGuid
[in] The unique identifier of the internal Curve Element.
api_analyticalRelease
[out] The Structural Analytical Model Member Release data.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Requirements

Version: API 24 or later
Header: .\ACAPI_Analytical_Adapter.hpp

 

See Also

API Functions