ACAPI_​AnalyticalModel_​GetCurveMemberCrossSection

Returns the Profile Vector Image of the specified cross Section profile.

    GSErrCode  ACAPI_AnalyticalModel_GetCurveMemberCrossSection (
        const API_Guid&                 amGuid,
        const API_Guid&                 elemGuid,
        API_AnalyticalCrossSection*     api_crossSection,
        ProfileVectorImage*             profileImage
    );

 

Parameters

amGuid
[in] The Analytical Model identifier.
elemGuid
[in] The Element identifier.
api_crossSection
[in] The Cross Section parameters.
profileImage
[out] The Vector Image of the Cross Section profile.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Requirements

Version: API 22 or later
Header: ACAPinc.h

 

See Also

API Functions