ACAPI_​AnalyticalModel_​GetCurveMemberProfileVectorImage

Returns the ProfileVectorImage of the Structural Analytical Model Curve Member associated with the selected Curve Element.

    GSErrCode  ACAPI_AnalyticalModel_GetCurveMemberProfileVectorImage (
        const API_Guid&         amGuid,
        const API_Guid&         elemGuid,
        ProfileVectorImage*     profileVectorImage
    );

 

Parameters

amGuid
[in] The unique identifier of the internal Structural Analytical Model.
elemGuid
[in] The unique identifier of the internal Curve Element.
profileVectorImage
[out] The ProfileVectorImage of the Curve Member Cross Section.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Requirements

Version: API 24 or later
Header: .\ACAPinc.h

 

See Also

API Functions