ACAPI_​AnalyticalModel_​GetSurfaceMember

Returns the Structural Analytical Model Surface Member associated with the selected Surface Element.

    GSErrCode  ACAPI_AnalyticalModel_GetSurfaceMember (
        const API_Guid&                  amGuid,
        const API_Guid&                  elemGuid,
        API_AnalyticalSurfaceMember&     surfaceMember
        API_ExportIdMappingType&         idMapping
    );

 

Parameters

amGuid
[in] The unique identifier of the internal Structural Analytical Model.
elemGuid
[in] The unique identifier of the internal Surface Element.
surfaceMember
[out] The Structural Analytical Model Surface Member data.
idMapping
[out] The mapping between support/link/release partID and member’s edge/vertex.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Requirements

Version: API 24 or later
Header: .\ACAPI_Analytical_Adapter.hpp

 

See Also

API Functions