ACAPI_​Attribute_​AddClassificationItem

Classifies an attribute.

    GSErrCode  ACAPI_Attribute_AddClassificationItem (
        const API_Attr_Head&        attrHead,
        const API_Guid&             itemGuid
    );

 

Parameters

attrHead
[in] Header of the attribute. The attribute is identified by typeID and index
itemGuid
[in] The guid of the classification item, that should be added to the element.

 

Return Values

NoError
The function has completed with success.
APIERR_BADINDEX
APIERR_DELETED
The attrHead did not refer to a valid attribute.
APIERR_READONLY
The attribute can not be modified (i.e. from a hotlink) or you do not have the right to classify attributes in the current teamwork plan.
APIERR_BADID
Inexistent classification item.
APIERR_BADCLASSIFICATION
The classification item is not available for the given attribute.

For other common API errors see the API Errors document.

 

Example

For detailed examples, please see the Classification_Test add-on.

 

Requirements

Version:API 23 or later
Header: ACAPinc.h

 

See Also

Classification,
API Functions