Enables the attribute folder picker functionality for a push check, if the user clicks the push check, the picker will open. Attributes folder pickers can be used to choose an attribute folder.
GSErrCode ACAPI_Attribute_CreateAttributeFolderPicker ( const API_AttributeFolderPickerParams& attributeFolderPickerParams, GS::Owner<API_AttributeFolderPicker>& attributeFolderPicker );
Parameters
- attributeFolderPickerParams
- [in] Parameters of attribute folder picker (type of the attribute, the parameters of push check).
- attributeFolderPicker
- [out] The constructed picker.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- Incorrect
attributeFolderPickerParams
was specified.
For other common API errors see the API Errors document.
Requirements
- Version: API 26 or later
- Header: ACAPinc.h