ACAPI_​Attribute_​DeleteFolder

Deletes an attribute folder and all the folders and attributes it contains.

    GSErrCode  ACAPI_Attribute_DeleteFolder (
        const API_AttributeFolder&        folder
    );

 

Parameters

folder
[in] The folder to delete.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Incorrect folder was specified.
APIERR_NOPLAN
There is no open project.
APIERR_NOACCESSRIGHT
User has no permission to delete folders under folder.typeID.
APIERR_NOTMINE
Attribute type folder.typeID is not reserved.

For other common API errors see the API Errors document.

 

Remarks

Folder has to be an existing folder identified by it’s typeID, and path or guid..

Deletes all deletable attributes and folders the given folder contains. If an attribute is not deletable, the folders containing the attribute are not deleted.

 

Example

API_AttributeFolder lineFolder {};
lineFolder.typeID = API_LinetypeID;
lineFolder.path = { "A", "B", "C" };
ACAPI_Attribute_DeleteFolder (lineFolder);

API_AttributeFolder cwFolder {};
cwFolder.typeID = API_CompWallID;
cwFolder.guid = GS::Guid ("27075EFF-611F-4B11-9BBB-553AC8BDA922");
ACAPI_Attribute_DeleteFolder (cwFolder);
        

 

Requirements

Version: API 26 or later
Header: ACAPinc.h

 

See Also

ACAPI_Attribute_GetFolder,
ACAPI_Attribute_CreateFolder,
ACAPI_Attribute_RenameFolder,
ACAPI_Attribute_GetFolderContent,
ACAPI_Attribute_Move,
API Functions