Deletes more attributes of the same type.
GSErrCode ACAPI_Attribute_DeleteMore ( API_AttrTypeID attrTypeID, const GS::Array<API_AttributeIndex>& attrIndexList );
Parameters
- attrTypeID
- [in] Identifies the type of the attributes to delete.
- attrIndexList
- [in] List of attribute indices to be deleted.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The passed parameter
attrTypeID
is invalid or the givenattrIndexList
is empty. APIERR_REFUSEDPAR
- You tried to delete pens, fonts, a solid or an empty fill, or an attribute with index 1.
APIERR_NOTMINE
- The attribute is out of the users workspace.
For other common API errors see the API Errors document.
Remarks
This function is the extension of ACAPI_Attribute_Delete. You can specify a list of attribute indices to be deleted. If you pass only one index in the attrIndexList
parameter, this function works like ACAPI_Attribute_Delete.
This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.
Example
GSErrCode err = ACAPI_Attribute_DeleteMore (API_LinetypeID, { 3, 4, 5 }); if (err != NoError) { // failed to delete the attributes }
Requirements
- Version: API 11 or later
- Header: ACAPinc.h
See Also
API_Attr_Head, API_AttributeIndex
ACAPI_Attribute_Delete
Attribute Manager
API Functions