Retrieves an array containing information about attributes of type typeID
from a file.
GSErrCode ACAPI_Attribute_GetAttributeByNameFromProject ( const IO::Location& location, API_AttrTypeID typeID, GS::Array<GS::Pair<API_Attribute, API_AttributeDefExt>>* resultArray );
Parameters
- location
- [in] Location of the template file
- typeID
- [in] Type of attribute to be searched
- resultArray
- [out] Contains pairs of API_Attribute and API_AttributeDefExt for each attribute of type
typeID
found in the template file.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The project could not be opened using the parameter
location
APIERR_GENERAL
- Various internal errors
For other common API errors see the API Errors document.