Retrieves all of the classifications of an attribute.
GSErrCode ACAPI_Attribute_GetClassificationItems ( const API_Attr_Head& attrHead, GS::Array<GS::Pair<API_Guid, API_Guid>>& systemItemPairs );
Parameters
- attrHead
- [in] Header of the attribute. The attribute is identified by typeID and index
- systemItemPairs
- [out] A list of classification system and classification item guid pairs, that represent the attribute’s classifications.
Return Values
NoError
- The function has completed with success.
APIERR_BADINDEX
APIERR_DELETED
- The attrHead did not refer to a valid attribute.
APIERR_GENERAL
- Internal error.
For other common API errors see the API Errors document.
Example
For detailed examples, please see the Classification_Test add-on.
Requirements
- Version:API 23 or later
- Header: ACAPinc.h