Returns an attribute reader for the currently used attribute set.
Modeler::IAttributeReader* ACAPI_Attribute_GetCurrentAttributeSetReader ();
Remarks
Use this function when an attribute reader is required as a parameter of other functions. For example when retrieving the 3D model by using the EXPGetModel function.
The returned attribute reader is allocated on the heap. Don’t forget to delete it when it’s not needed anymore!
Example
For detailed examples, please see the ModelAccess_Test or the Model3DViewer_Test example add-ons.
Requirements
- Version: API 26 or later
- Header: ACAPinc.h