ACAPI_​Attribute_​GetFolder

Retrieves an existing attribute folder by it’s path or guid.

    GSErrCode  ACAPI_Attribute_GetFolder (
        API_AttributeFolder&        folder
    );

 

Parameters

folder
[in out] Set the typeID and the path or guid of the attribute folder to retrieve.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
Incorrect folder.typeID was specified, or folder.path is illegal, see remarks.
APIERR_NOPLAN
There is no open project.

For other common API errors see the API Errors document.

 

Remarks

folder.path has to be legal, i.e. all names in the array must not be empty, and must not begin or end with whitespace.

Besides folder.typeID, either folder.guid or folder.path is to be passed.
If none of the latter is provided, the root folder is accessed.

 

Example


API_AttributeFolder folder {};
folder.typeID = API_LinetypeID;
folder.guid = GS::Guid ("27075EFF-611F-4B11-9BBB-553AC8BDA922");
DBVERIFY (ACAPI_Attribute_GetFolder (folder) == NoError);
for (const auto& name : folder.path) {
    // ...
}
        

 

Requirements

Version: API 26 or later
Header: ACAPinc.h

 

See Also

ACAPI_Attribute_CreateFolder,
ACAPI_Attribute_DeleteFolder,
ACAPI_Attribute_RenameFolder,
ACAPI_Attribute_GetFolderContent,
ACAPI_Attribute_Move,
API Functions