Returns all folders and attributes of an attribute type.
GSErrCode ACAPI_Attribute_GetFolderContent ( const API_AttributeFolder& folder, API_AttributeFolderContent& result );
Parameters
- folder
- [in] Identifier of the folder to query.
- result
- [out] Content of te queried folder.
Return Values
NoError
- The function has completed with success.
APIERR_BADID
- Incorrect
folder
was specified. APIERR_NOPLAN
- There is no open project.
For other common API errors see the API Errors document.
Requirements
- Version: API 26 or later
- Header: ACAPinc.h
See Also
API_AttributeFolderContent,
ACAPI_Attribute_GetFolder,
ACAPI_Attribute_CreateFolder,
ACAPI_Attribute_DeleteFolder,
ACAPI_Attribute_RenameFolder,
ACAPI_Attribute_Move,
API Functions