ACAPI_​Attribute_​GetPropertyValuesByGuid

Retrieves the property values of the property definitions.

    GSErrCode  ACAPI_Attribute_GetPropertyValuesByGuid (
        const API_Attr_Head&                   attrHead,
        GS::Array<API_Guid>&                   propertyDefinitions
        GS::Array<API_Property&                properties
    );

 

Parameters

attrHead
[in] Header of the attribute. The attribute is identified by typeID and index
propertyDefinitions
[in] List of property definitions identified by guid.
properties
[out] List of property values.

 

Return Values

NoError
The function has completed with success.
APIERR_BADINDEX
APIERR_DELETED
The attrHead did not refer to a valid attribute.
APIERR_GENERAL
Every other case.

For other common API errors see the API Errors document.

Requirements

Version:API 23 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions