ACAPI_​Attribute_​RenameFolder

Deletes an attribute folder and all the folders and attributes it contains.

    GSErrCode  ACAPI_Attribute_DeleteFolder (
        const API_AttributeFolder&        folder,
        const GS::UniString&              newName,
    );

 

Parameters

folder
[in] The folder to rename.
newName
[in] The new name for the folder.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Incorrect folder was specified.
APIERR_NOPLAN
There is no open project.
APIERR_NOACCESSRIGHT
User has no permission to rename folders under folder.typeID.
APIERR_NOTMINE
Attribute type folder.typeID is not reserved.

For other common API errors see the API Errors document.

 

Remarks

Folder has to be an existing folder identified by it’s typeID, and path or guid..

newName has to be legal, must not be empty, and must not begin or end with whitespace.

Renames the specified folder (while preserving it’s guid). The root folder can’t be renamed, two folders in the same parent folder can’t have the same name.

 

Requirements

Version: API 26 or later
Header: ACAPinc.h

 

See Also

ACAPI_Attribute_GetFolder,
ACAPI_Attribute_CreateFolder,
ACAPI_Attribute_DeleteFolder,
ACAPI_Attribute_GetFolderContent,
ACAPI_Attribute_Move,
API Functions