ACAPI_​Attribute_​SetProperty

Sets the property value of the property definition.

    GSErrCode  ACAPI_Attribute_SetProperty (
        const API_Attr_Head&               attrHead,
        const API_Property&                property
    );

 

Parameters

attrHead
[in] Header of the attribute. The attribute is identified by typeID and index
property
[in] Property.

 

Return Values

NoError
The function has completed with success.
APIERR_BADINDEX
APIERR_DELETED
The attrHead did not refer to a valid attribute.
APIERR_NOACCESSRIGHT
The property can not be modified because you do not have the right to classify attributes in the current teamwork plan.
APIERR_READONLY
The proeprty can not be modified because it is readonly.
APIERR_BADID
Inexistent propert item.
APIERR_GENERAL
Every other case.

For other common API errors see the API Errors document.

Requirements

Version:API 23 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions