ACAPI_​AttributeList_​ModifyPropertyValue

Sets the value of a property for multiple attributes. If the property is not available for at least one of the given attribute then returns with an error without changing any property value.

    GSErrCode  ACAPI_AttributeList_ModifyPropertyValue (
        const API_Property&                 property,
        const GS::Array<API_Attr_Head>&     attrHeaders
    );

 

Parameters

property
[in] The new value of the property.
attrHeaders
[in] The array of attributes, that the property should be available for.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
Inexistent property item.
APIERR_NOACCESSRIGHT
The current user does not have the right to modify the properties of a specified attribute on a teamwork server.
APIERR_READONLY
Tried to modify a read-only property (for example a property coming from a hotlink).
APIERR_BADPROPERTY
The property definition is not available for one of the given attributes.

For other common API errors see the API Errors document.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions