ACAPI_​Automate

Actuates the server application as an automation server.

    GSErrCode  ACAPI_Automate (
        API_AutomateID     code,
        void*              par1 = nullptr,
        void*              par2 = nullptr,
        void*              par3 = nullptr
    );

 

Parameters

code
[in] Automation function identifier.
par1
[in/out] The content of par1 depends on the code parameter.
par2
[in/out] The content of par2 depends on the code parameter.
par3
[in/out] The content of par2 depends on the code parameter.

 

Return Values

NoError
The automation function completed with success.
APIERR_BADID
Invalid code parameter was passed.
APIERR_REFUSEDCMD
The requested function is not available.

More return values can be found at the description of each automation functions.

 

Remarks

This function group is used to actuate the host application from an API tool add-on.

The type of the automation function is specified by the code parameter.

API_AutomateID

Description

 

 

File Operations

 

APIDo_NewProjectID

Opens a new plan.

APIDo_OpenID

Opens an existing project file.

APIDo_CloseID

Closes the current window.

APIDo_SaveID

Saves the content of the current window in different file formats.

APIDo_SaveAsModuleFileID

Saves the selected elements into a module file.

APIDo_LoadLibrariesID

Resets and loads the active libraries.

APIDo_ReloadLibrariesID  Featuring API 21

Reloads the active libraries.

APIDo_PrintID

Prints the content of the current window.

APIDo_QuitID

Terminates the server application.

 

 

Display and View

 

APIDo_RedrawID

Redraws the content of the current window.

APIDo_RebuildID

Rebuilds the content of the current window.

APIDo_ZoomID

Performs a zoom operation.

APIDo_ZoomToSelectedID

Zooms to the selected elements.

APIDo_ZoomToElementsID  Featuring API 21

Zooms to the given set of elements.

APIDo_ChangeWindowID

Changes the front window.

APIDo_GoToViewID  Featuring API 10

Switches to the given navigator view.

APIDo_PhotoRenderID

Creates a photorealistic image of the 3D window.

APIDo_ShowSelectionIn3DID Featuring API 10

Show Selection/Marquee in 3D.

APIDo_ShowAllIn3DID Featuring API 10

Show All in 3D.

 

 

Hierarchical elements (curtain wall, stair, railing) related functions

 

APIDo_EditHierarchicalElemID  Featuring API 22

Change to Hierarchical Elem (Curtain Wall, Stair, Railing, Beam, Column) Editing mode.

APIDo_CancelHierarchicalElemID  Featuring API 22

Cancel changes in Hierarchical Elem (Curtain Wall, Stair, Railing, Beam, Column) editing mode.

APIDo_OkHierarchicalElemID  Featuring API 22

Accept changes in Hierarchical Elem (Curtain Wall, Stair, Railing, Beam, Column) editing mode.

  

Requirements

Version: API 2.1 or later
Header: ACAPinc.h

 

See Also

General Functions, API Functions