ACAPI_​Body_​Finish

Converts the body data object to a format, that can be passed to an API_ElementMemo structure.

    GSErrCode  ACAPI_Body_Finish (
        void*                         bodyData,
        Modeler::MeshBody**           body,
        API_OverriddenAttribute**     bodyMaterialMapTable
    );

 

Parameters

bodyData
[in] The body data object to convert.
body Changed in API 22
[out] The body object to put the resulting body to.
bodyMaterialMapTable Featuring API 17
[out] The material override structure list of the polygons of the body.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The passed parameter is nullptr; bodyData, body

For other common API errors see the API Errors document.

 

Remarks

This function is used to convert a body data object to data, that can be passed to an API_ElementMemo structure and create a morph element.

 

Example

See the example of the ACAPI_Body_Create function.

 

Requirements

Version: API 16 or later
Header: ACAPinc.h

 

See Also

ACAPI_Body_Create, ACAPI_Body_Dispose,
ACAPI_Body_AddVertex, ACAPI_Body_AddEdge, ACAPI_Body_AddPolyNormal, ACAPI_Body_AddPolygon,
Body Manager, API Functions