ACAPI_​CallCommand

Performs an operation without opening an undoable session.

    GSErrCode  ACAPI_CallCommand (
        const GS::UniString&                commandName
        const std::function<GSErrCode ()>&  command
    );

 

Parameters

commandName
[in] Reserved for further use, this string won’t appear anywhere.
command
[in] The lambda function (C++11 function wrapper) that encapsulates all the operations.

 

Return Values

NoError
The function has completed with success.
APIERR_REFUSEDCMD
An operation has already opened, or the current command is undoable.
APIERR_COMMANDFAILED
The current command threw an exception.
 

For other common API errors see the API Errors document.

 

Remarks

This function is used to execute more not-undoable data structure modifier functions in a single command.

 

Requirements

Version: API 19 or later
Header: ACAPinc.h

 

See Also

ACAPI_CallUndoableCommand, API Functions