ACAPI_​Classification_​ChangeClassificationItem

Modifies a classification item.

        GSErrCode  ACAPI_Classification_ChangeClassificationItem (
            const API_ClassificationItem&    item
        );
    

 

Parameters

item
[in] The details of the classification item.

 

Return Values

NoError
The function has completed with success.
APIERR_NOACCESSRIGHT
Don’t have the right to modify a classification item in this plan.
APIERR_BADID
The item.guid does not refer to a valid classification item.
APIERR_READONLY
The referenced classification item can not be modified (i.e. comes from a hotlink).
APIERR_BADNAME
The item.id is not a valid identifier for a classification item (i.e. empty string).
APIERR_NAMEALREADYUSED
The item.id is different than the current id of the referenced item and the new id is already used as a classification item id in the item’s system.

For other common API errors see the API Errors document.

 

Example

For detailed examples, please see the Classification_Test add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

Classification,
API Functions