ACAPI_​Classification_​ChangeClassificationSystem

Modifies a classification system.

        GSErrCode  ACAPI_Classification_ChangeClassificationSystem (
            const API_ClassificationSystem&    system
        );
    

 

Parameters

system
[in] The details of the classification system.

 

Return Values

NoError
The function has completed with success.
APIERR_NOACCESSRIGHT
Don’t have the right to modify a classification system in this plan.
APIERR_BADID
The guid of the system parameter does not refer to a valid classification system.
APIERR_READONLY
The referenced classification system can not be modified (i.e. comes from a hotlink).
APIERR_BADNAME
The name field of the system is not a valid name for a classification system (i.e. empty string).
APIERR_NAMEALREADYUSED
The name field of the system is different than the current name of the referenced classification system, but the new name is already used as a classification name in the current plan.
APIERR_BADPARS
The editionDate field of the system is not a valid date.

For other common API errors see the API Errors document.

 

Example

For detailed examples, please see the Classification_Test add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

Classification,
API Functions