ACAPI_​Classification_​CreateClassificationItem

Creates a classification item.

        GSErrCode  ACAPI_Classification_CreateClassificationItem (
            API_ClassificationItem&                 item,
            const API_Guid&                         systemGuid,
            const API_Guid&                         parentItemGuid,
            const API_Guid&                         nextItemGuid
        );
    

 

Parameters

item
[in] The details of the classification item to create.
[out] The guid of the created classification item.
systemGuid
[in] The guid of the classification system in which the item should be created.
parentItemGuid
[in] The guid of the item that should be the parent of the newly created item (or null guid, if it should be a root item).
nextItemGuid
[in] The guid of the item that should next in order to the created item (or null guid, if it created item should be the last).

 

Return Values

NoError
The function has completed with success.
APIERR_NOACCESSRIGHT
Don’t have the right to create a classification item in this plan.
APIERR_BADID
One of the parameter guids did not refer to a valid object.
APIERR_BADPARS
The given parent item is in a different system or the given next item is not on the same level as the item to be created.
APIERR_BADNAME
The id field of the item is not a valid identifier for a classification item (i.e. empty string).
APIERR_NAMEALREADYUSED
The id field of the item is already used as a classification item id within the given system.

For other common API errors see the API Errors document.

 

Example

For detailed examples, please see the Classification_Test add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

Classification,
API Functions