ACAPI_​Classification_​CreateClassificationSystem

Creates a classification system.

        GSErrCode  ACAPI_Classification_CreateClassificationSystem (
            API_ClassificationSystem&       system
        );
    

 

Parameters

system
[in] The details of the classification system to create.
[out] The guid of the created classification system.

 

Return Values

NoError
The function has completed with success.
APIERR_NOACCESSRIGHT
Don’t have the right to create a classification system in this plan.
APIERR_BADNAME
The name field of the system is not a valid name for a classification system (i.e. empty string).
APIERR_NAMEALREADYUSED
The name field of the system is already used as a classification system name in the current plan with the same edition version.
APIERR_BADPARS
The editionDate field of the system is not a valid date.

For other common API errors see the API Errors document.

 

Example

For detailed examples, please see the Classification_Test add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

Classification,
API Functions