ACAPI_​Classification_​GetClassificationItemChildren

Retrieves the children of a classification item.

        GSErrCode  ACAPI_Classification_GetClassificationItemChildren (
            const API_Guid&                              itemGuid
            GS::Array<API_ClassificationItem>&           children
        );
    

 

Parameters

itemGuid
[in] The guid of the item whose children should be retrieved.
children
[out] The retrieved children classification items.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The itemGuid did not refer to a valid classification item.

For other common API errors see the API Errors document.

 

Example

For detailed examples, please see the Classification_Test add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

Classification,
API Functions