Imports a classification xml.
GSErrCode ACAPI_Classification_Import ( const GS::UniString& classificationXml, API_ClassificationSystemNameConflictResolutionPolicy systemConflictPolicy, API_ClassificationItemNameConflictResolutionPolicy itemConflictPolicy );
Parameters
- classificationXml
- [in] The classification xml to import.
- systemConflictPolicy
- [in] Specifies how to resolve classification system conflicts.
Meaning
API_MergeConflictingSystems
Merge the conflicting systems
API_ReplaceConflictingSystems
Replace the system in the plan with the imported one
API_SkipConflictingSystems
Keep the system in the plan intact, and discard the imported one
- itemConflictPolicy
- [in] Specifies how to resolve classification item conflicts.
Meaning
API_ReplaceConflictingItems
Replace the item in the plan with the imported one
API_SkipConflicitingItems
Keep the item in the plan intact, and discard the imported one
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- Invalid classification XML.
For other common API errors see the API Errors document.
Example
For detailed examples, please see the Classification_Test add-on.
Requirements
- Version: API 21 or later
- Header: ACAPinc.h