Sets the 3D default levels for the passed construction element types.
GSErrCode ACAPI_Database_SetLast3DDefLevels ( const GS::Array<API_ElemTypeID>& elemTypes, const GS::Array<double>& levels );
Parameters
- elemTypes
- [in] Elem types for which you want to set the 3D default levels.
- levels
- [in] The default 3D level values.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The size of
elemTypes
differes from the size oflevels
.
For other common API errors see the API Errors document.
Remarks
Sets the 3D default levels for the given elemtypes. Possible elemtypes: Wall, Column, Beam, Symbol, Light, Slab, Roof, Mesh.
Requirements
- Version: API 26 or later
- Header: ACAPinc.h