ACAPI_​DisposeAttrDefsHdls

Frees the memory occupied by all of the attribute definition handles.

    void  ACAPI_DisposeAttrDefsHdls (
        API_AttributeDef*     defs
    );

 

Parameters

defs
[in] Points to an API_AttributeDef structure which contains handles used for previous operations and not needed any more.

 

Remarks

This is the recommended way of disposing the attribute definition handles for compatibility reasons, as in a later version of the API the API_AttributeDef structure might change.

 

Requirements

Version: API 1.3 or later
Header: ACAPinc.h

 

See Also

API_AttributeDef,
ACAPI_Attribute_GetDef,
Memory Manager, API Functions