ACAPI_​DisposeBeamSegmentRelationHdls

Frees the memory occupied by all of the allocated beam segment relation handles.

    void  ACAPI_DisposeBeamSegmentRelationHdls (
        API_BeamSegmentRelation*     segmentInfo
    );

 

Parameters

segmentInfo
[in] Points to an API_BeamSegmentRelation structure which contains handles used for previous operations and not needed any more.

 

Remarks

This is the recommended way of disposing the beam segment relation handles for compatibility reasons, as in a later version of the API the API_BeamSegmentRelation structure might change.

  

Requirements

Version: API 23 or later
Header: ACAPinc.h

 

See Also

API_BeamSegmentRelation,
ACAPI_Element_GetRelations,
Memory Manager, API Functions