ACAPI_​ElemComponent_​GetPropertyDefinitions

Retrieves all of the property definitions that are available for a component of an element.

    GSErrCode  ACAPI_ElemComponent_GetPropertyDefinitions (
        const API_ElemComponentID&             elemComponent,
        API_PropertyDefinitionFilter           filter,
        GS::Array<API_PropertyDefinition>&     propertyDefinitions
    );
    

 

Parameters

elemComponent
[in] The identifier of the element’s component to search for.
filter
[in] Filter the list of property definitions (API_PropertyDefinitionFilter_UserDefined, API_PropertyDefinitionFilter_BuiltIn, API_PropertyDefinitionFilter_All).
propertyDefinitions
[out] Array of property definitions that are available for the given component.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The value of elemComponent did not refer to a valid component.

For other common API errors see the API Errors document.

 

Example


GSErrCode GetPropertyDefinitionNames (const API_ElemComponentID& elemComponent, GS::Array<GS::UniString>& names)
{
    GS::Array<API_PropertyDefinition> definitions;
    const GSErrCode error = ACAPI_ElemComponent_GetPropertyDefinitions (elemComponent, API_PropertyDefinitionFilter_All, definitions);
    if (error == NoError) {
        for (UInt32 i = 0; i < definitions.GetSize (); ++i) {
            names.Push (definitions[i].name);
        }
    }

    return error;
}
        

Requirements

Version: API 25 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions