ACAPI_​ElemComponent_​GetPropertyValues

Retrieves the values of the specified property definitions from the component.

    GSErrCode  ACAPI_ElemComponent_GetPropertyValues (
        const API_ElemComponentID&                   elemComponent,
        const GS::Array<API_PropertyDefinition>&     propertyDefinitions,
        GS::Array<API_Property>&                     properties
    );
    

 

Parameters

elemComponent
[in] The identifier of the element’s component to search for.
propertyDefinitions
[in] The property definitions to get the values for.
properties
[out] The definitions and values of the requested properties.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The elemComponent did not refer to a valid element.

For other common API errors see the API Errors document.

 

Example


GSErrCode GetAllPropertyValues (const API_ElemComponentID& elemComponent, GS::Array<API_PropertyValue>& values)
{
    GS::Array<API_PropertyDefinition> definitions;
    GSErrCode error = ACAPI_ElemComponent_GetPropertyDefinitions (elemComponent, API_PropertyDefinitionFilter_All, definitions);
    if (error == NoError) {
        GS::Array<API_Property> properties;
        error = ACAPI_ElemComponent_GetPropertyValues (elemComponent, definitions, properties);
        if (error == NoError) {
            for (UInt32 i = 0; i < properties.GetSize (); i++) {
                if (properties[i].isDefault) {
                    values.Push (properties[i].definition.defaultValue.basicValue);
                } else {
                    values.Push (properties[i].value);
                }
            }
        }
    }

    return error;
}
        

 

Requirements

Version: API 25 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions